Friday, July 1, 2011

Symfony 1.0 дээр хийгдсэн project -ийг PHP 5.3-тай сервер дээр ажиллуулах

Хэдэн сарын өмнө Symfony 1.0 дээр хийгдсэн project -ийг PHP 5.3-тай сервер дээр ажиллуулах гээд болоогүй юм. Гэтэл саяхан интернэтээр хэсэж явтал гэнэт шийдэл нь гараад ирдэг байгаа.
Тэгээд нөгөө болж өгөөгүй вэбээ янзалчихаад бичиж сууна.

Configuration file "D:\web\projectName\config/../data/symfony/config/php.yml" specifies key "zend.ze1_compatibility_mode" which is not a php.ini directive

гэсэн ийм утгатай алдаа заадаг.

Тэгвэл үүнийг шийдэхийн тулд:

data/symfony/config/php.yml файлыг нээгээд
zend.ze1_compatibility_mode: мөрийг comment болгочихоно.

Тэгээд болоо.

1 comment:

tume said...

./data/symfony/config/php.yml

ene file deer uu